grthtrhthjhtyjytjytkergtrhtrjytjerhrfhU iÛf“$ã@s„dZdZddlZdZdZGdd„deƒZGdd „d eƒZd d „Zd=d d„Z dd„Z dd„Z dd„Z dd„Z dd„Zdd„Zdd„Zdd„Zdd „Zd!d"„ZGd#d$„d$ƒZejGd%d&„d&eƒƒZejGd'd(„d(eƒƒZGd)d*„d*ƒZGd+d,„d,eeƒZGd-d.„d.eƒZGd/d0„d0eeƒZGd1d2„d2ƒZee_Gd3d4„d4ƒZGd5d6„d6eeƒZGd7d8„d8eƒZ Gd9d:„d:eeƒZ!Gd;d<„d<ƒZ"e"e_dS)>z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0éNé é€c@seZdZdZdS)ÚAddressValueErrorz%A Value Error related to the address.N©Ú__name__Ú __module__Ú __qualname__Ú__doc__©r r ú./opt/alt/python38/lib64/python3.8/ipaddress.pyrsrc@seZdZdZdS)ÚNetmaskValueErrorz%A Value Error related to the netmask.Nrr r r r r sr c CsXz t|ƒWSttfk r"YnXz t|ƒWSttfk rFYnXtd|ƒ‚dS)a®Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z0%r does not appear to be an IPv4 or IPv6 addressN)Ú IPv4Addressrr Ú IPv6AddressÚ ValueError©Úaddressr r r Ú ip_addresss  ÿrTc Cs\z t||ƒWSttfk r$YnXz t||ƒWSttfk rJYnXtd|ƒ‚dS)aÐTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z0%r does not appear to be an IPv4 or IPv6 networkN)Ú IPv4Networkrr Ú IPv6Networkr)rÚstrictr r r Ú ip_network9s  ÿrc CsXz t|ƒWSttfk r"YnXz t|ƒWSttfk rFYnXtd|ƒ‚dS)agTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z2%r does not appear to be an IPv4 or IPv6 interfaceN)Ú IPv4Interfacerr Ú IPv6Interfacerrr r r Ú ip_interfaceWs  ÿrcCs0z| dd¡WStk r*tdƒ‚YnXdS)a`Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. éÚbigz&Address negative or too large for IPv4N©Úto_bytesÚ OverflowErrorrrr r r Úv4_int_to_packedzsrcCs0z| dd¡WStk r*tdƒ‚YnXdS)zõRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. érz&Address negative or too large for IPv6Nrrr r r Úv6_int_to_packedŽs r!cCs*t|ƒ d¡}t|ƒdkr&td|ƒ‚|S)zAHelper to split the netmask and raise AddressValueError if neededú/ézOnly one '/' permitted in %r)ÚstrÚsplitÚlenr)rÚaddrr r r Ú_split_optional_netmaskžs  r(ccsNt|ƒ}t|ƒ}}|D]&}|j|jdkr:||fV|}|}q||fVdS)zÏFind a sequence of sorted deduplicated IPv#Address. Args: addresses: a list of IPv#Address objects. Yields: A tuple containing the first and last IP addresses in the sequence. éN)ÚiterÚnextÚ_ip)Ú addressesÚitÚfirstÚlastÚipr r r Ú_find_address_range¦s   r2cCs$|dkr |St|||d@ ¡ƒS)zåCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. rr))ÚminÚ bit_length)ZnumberÚbitsr r r Ú_count_righthand_zero_bitsºs r6ccsât|tƒrt|tƒstdƒ‚|j|jkr8td||fƒ‚||krHtdƒ‚|jdkrXt}n|jdkrht}ntdƒ‚|j}|j}|j}||krÞt t ||ƒ||d  ¡dƒ}||||fƒ}|V|d|>7}|d|j kr‚qÞq‚dS) a¤Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksú%%s and %s are not of the same versionz*last IP address must be greater than firstrézunknown IP versionr)N) Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrrÚ_max_prefixlenr,r3r6r4Ú _ALL_ONES)r/r0r1Zip_bitsZ first_intZlast_intZnbitsÚnetr r r Úsummarize_address_rangeÊs8 ÿ ÿ   ÿ r@ccs�t|ƒ}i}|rV| ¡}| ¡}| |¡}|dkr<|||<q ||kr ||=| |¡q d}t| ¡ƒD]$}|dk r€|j|jkr€qf|V|}qfdS)auLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)r-Zto_mergeÚsubnetsr?rCZexistingr0r r r Ú_collapse_addresses_internals$    rJc Cs0g}g}g}|D]Ü}t|tƒrR|rF|dj|jkrFtd||dfƒ‚| |¡q|j|jkrº|r†|dj|jkr†td||dfƒ‚z| |j¡Wqìtk r¶| |j ¡YqìXq|râ|dj|jkrâtd||dfƒ‚| |¡qt t |ƒƒ}|�r$t |ƒD]\}}|  t||ƒ¡�qt||ƒS)aËCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterator of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. éÿÿÿÿr7)r9r:Ú_versionr;rEÚ _prefixlenr=r1ÚAttributeErrorÚnetwork_addressrFÚsetr2Úextendr@rJ)r-ZaddrsZipsZnetsr1r/r0r r r Úcollapse_addresses2s@ ÿ  ÿÿ  rRcCs(t|tƒr| ¡St|tƒr$| ¡StS)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )r9Ú _BaseNetworkÚ_get_networks_keyr:Ú_get_address_keyÚNotImplemented)Úobjr r r Úget_mixed_type_keyhs   rXc@s¤eZdZdZdZedd„ƒZedd„ƒZedd„ƒZed d „ƒZ d d „Z d d„Z e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdd„ZdS)Ú_IPAddressBasezThe mother class.r cCs| ¡S)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string©Úselfr r r Úexploded‡sz_IPAddressBase.explodedcCst|ƒS)z;Return the shorthand version of the IP address as a string.©r$r[r r r Ú compressedŒsz_IPAddressBase.compressedcCs| ¡S)aIThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointerr[r r r Úreverse_pointer‘s z_IPAddressBase.reverse_pointercCsdt|ƒf}t|ƒ‚dS)Nz%200s has no version specified©ÚtypeÚNotImplementedError©r\Úmsgr r r r<œsz_IPAddressBase.versioncCsF|dkrd}t|||jfƒ‚||jkrBd}t|||j|jfƒ‚dS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)rrLr>r=)r\rrfr r r Ú_check_int_address¡s  ÿz!_IPAddressBase._check_int_addresscCs.t|ƒ}||kr*d}t|||||jfƒ‚dS)Nz6%r (len %d != %d) is not permitted as an IPv%d address)r&rrL)r\rZ expected_lenZ address_lenrfr r r Ú_check_packed_addressªsÿz$_IPAddressBase._check_packed_addresscCs|j|j|?AS)z¦Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )r>)ÚclsÚ prefixlenr r r Ú_ip_int_from_prefix±s z"_IPAddressBase._ip_int_from_prefixc Cs\t||jƒ}|j|}||?}d|>d}||krX|jd}| |d¡}d}t||ƒ‚|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r)érz&Netmask pattern %r mixes zeroes & ones)r6r=rr) riÚip_intZtrailing_zeroesrjZ leading_onesZall_onesZbyteslenZdetailsrfr r r Ú_prefix_from_ip_int¾s ÿ     z"_IPAddressBase._prefix_from_ip_intcCsd|}t|ƒd‚dS)Nz%r is not a valid netmask)r )riZ netmask_strrfr r r Ú_report_invalid_netmask×sz&_IPAddressBase._report_invalid_netmaskcCsl| ¡r| ¡s| |¡z t|ƒ}Wntk rD| |¡YnXd|kr\|jkshn| |¡|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)ÚisasciiÚisdigitroÚintrr=)riZ prefixlen_strrjr r r Ú_prefix_from_prefix_stringÜs   z)_IPAddressBase._prefix_from_prefix_stringcCsŠz| |¡}Wntk r,| |¡YnXz | |¡WStk rNYnX||jN}z | |¡WStk r„| |¡YnXdS)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrrornrr>)riÚip_strrmr r r Ú_prefix_from_ip_stringõs   z%_IPAddressBase._prefix_from_ip_stringcCsHt|ttfƒr||jfSt|tƒs*t|ƒ}t|ƒdkr:|S|d|jfS)zµHelper function to parse address of Network/Interface. Arg: address: Argument of Network/Interface. Returns: (addr, prefix) tuple. r)r)r9Úbytesrrr=Útupler(r&)rirr r r Ú_split_addr_prefixs    z!_IPAddressBase._split_addr_prefixcCs|jt|ƒffS©N)Ú __class__r$r[r r r Ú __reduce__/sz_IPAddressBase.__reduce__N)rrrr Ú __slots__Úpropertyr]r_rar<rgrhÚ classmethodrkrnrorsrvryr|r r r r rY�s2          ! rYc@sdeZdZdZdZdd„Zdd„Zdd„Zd d „Zd d „Z d d„Z dd„Z dd„Z dd„Z dd„ZdS)r:z€A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. r cCs|jSrz©r,r[r r r Ú__int__>sz_BaseAddress.__int__cCs8z|j|jko|j|jkWStk r2tYSXdSrz)r,rLrNrV©r\Úotherr r r Ú__eq__As   ÿz_BaseAddress.__eq__cCsFt|tƒstS|j|jkr*td||fƒ‚|j|jkrB|j|jkSdS©Nr7F)r9r:rVrLr;r,r‚r r r Ú__lt__Hs  ÿ  z_BaseAddress.__lt__cCs t|tƒstS| t|ƒ|¡Srz©r9rrrVr{r‚r r r Ú__add__Ts z_BaseAddress.__add__cCs t|tƒstS| t|ƒ|¡Srzr‡r‚r r r Ú__sub__Ys z_BaseAddress.__sub__cCsd|jjt|ƒfS©Nz%s(%r)©r{rr$r[r r r Ú__repr__^sz_BaseAddress.__repr__cCst| |j¡ƒSrz)r$Ú_string_from_ip_intr,r[r r r Ú__str__asz_BaseAddress.__str__cCsttt|jƒƒƒSrz)ÚhashÚhexrrr,r[r r r Ú__hash__dsz_BaseAddress.__hash__cCs |j|fSrz©rLr[r r r rUgsz_BaseAddress._get_address_keycCs|j|jffSrz)r{r,r[r r r r|jsz_BaseAddress.__reduce__N)rrrr r}r�r„r†rˆr‰rŒrŽr‘rUr|r r r r r:3s r:c@s`eZdZdZdd„Zdd„Zdd„Zdd „Zd d „Zd d „Z dd„Z dd„Z dd„Z dd„Z ejdd„ƒZejdd„ƒZedd„ƒZedd„ƒZedd„ƒZed d!„ƒZed"d#„ƒZed$d%„ƒZd&d'„Zd(d)„Zd*d+„ZdFd.d/„ZdGd0d1„Zed2d3„ƒZed4d5„ƒZ d6d7„Z!d8d9„Z"ed:d;„ƒZ#edd?„ƒZ%ed@dA„ƒZ&edBdC„ƒZ'edDdE„ƒZ(d-S)HrSz}A generic IP network object. This IP class contains the version independent methods which are used by networks. cCsd|jjt|ƒfSrŠr‹r[r r r rŒvsz_BaseNetwork.__repr__cCsd|j|jfS©Nú%s/%d)rOrjr[r r r rŽysz_BaseNetwork.__str__ccs8t|jƒ}t|jƒ}t|d|ƒD]}| |¡Vq"dS)zŸGenerate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r)N©rrrOrHÚrangeÚ_address_class©r\ÚnetworkÚ broadcastÚxr r r Úhosts|s  z_BaseNetwork.hostsccs8t|jƒ}t|jƒ}t||dƒD]}| |¡Vq"dS©Nr)r•r˜r r r Ú__iter__ˆs  z_BaseNetwork.__iter__cCslt|jƒ}t|jƒ}|dkr>|||kr0tdƒ‚| ||¡S|d7}|||krZtdƒ‚| ||¡SdS)Nrzaddress out of ranger))rrrOrHÚ IndexErrorr—)r\Únr™ršr r r Ú __getitem__Žs    z_BaseNetwork.__getitem__cCs^t|tƒstS|j|jkr*td||fƒ‚|j|jkrB|j|jkS|j|jkrZ|j|jkSdSr…)r9rSrVrLr;rOÚnetmaskr‚r r r r†›s  ÿ    z_BaseNetwork.__lt__cCsLz.|j|jko,|j|jko,t|jƒt|jƒkWStk rFtYSXdSrz)rLrOrrr¢rNrVr‚r r r r„§s  ÿþz_BaseNetwork.__eq__cCstt|jƒt|jƒAƒSrz)r�rrrOr¢r[r r r r‘¯sz_BaseNetwork.__hash__cCs8|j|jkrdSt|tƒrdS|j|jj@|jjkSdS©NF)rLr9rSr,r¢rOr‚r r r Ú __contains__²s   z_BaseNetwork.__contains__cCs(|j|kp&|j|kp&|j|kp&|j|kS)z*Tell if self is partly contained in other.)rOrHr‚r r r Úoverlaps¾s    ýz_BaseNetwork.overlapscCs| t|jƒt|jƒB¡Srz)r—rrrOÚhostmaskr[r r r rHÅs ÿz_BaseNetwork.broadcast_addresscCs| t|jƒ|jA¡Srz)r—rrr¢r>r[r r r r¦Êsz_BaseNetwork.hostmaskcCsd|j|jfSr“)rOrMr[r r r Úwith_prefixlenÎsz_BaseNetwork.with_prefixlencCsd|j|jfS©Nú%s/%s)rOr¢r[r r r Ú with_netmaskÒsz_BaseNetwork.with_netmaskcCsd|j|jfSr¨)rOr¦r[r r r Ú with_hostmaskÖsz_BaseNetwork.with_hostmaskcCst|jƒt|jƒdS)z&Number of hosts in the current subnet.r))rrrHrOr[r r r Ú num_addressesÚsz_BaseNetwork.num_addressescCsdt|ƒf}t|ƒ‚dS)Nz%%200s has no associated address classrbrer r r r—ßsz_BaseNetwork._address_classcCs|jSrz)rMr[r r r rjçsz_BaseNetwork.prefixlenccs|j|jkstd||fƒ‚t|tƒs2td|ƒ‚| |¡sLtd||fƒ‚||krXdS| d|j|jf¡}|  ¡\}}||krÚ||krÚ| |¡r¨|V|  ¡\}}qz| |¡rÆ|V|  ¡\}}qzt d|||fƒ‚qz||krê|Vn"||krú|Vnt d|||fƒ‚dS)aºRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. r7z%s is not a network objectz%s not contained in %sNr©z3Error performing exclusion: s1: %s s2: %s other: %s) rLr;r9rSÚ subnet_ofrr{rOrjrIÚAssertionError)r\rƒÚs1Ús2r r r Úaddress_excludeës@$ ÿ    ÿ   þþz_BaseNetwork.address_excludecCs`|j|jkrtd||fƒ‚|j|jkr,dS|j|jkr other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. z"%s and %s are not of the same typerKr)r)rLr;rOr¢r‚r r r Úcompare_networks6s! ÿ    z_BaseNetwork.compare_networkscCs|j|j|jfS)zËNetwork-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rLrOr¢r[r r r rTfsz_BaseNetwork._get_networks_keyr)Nc csÒ|j|jkr|VdS|dk rJ||jkr0tdƒ‚|dkr@tdƒ‚||j}|dkrZtdƒ‚|j|}||jkr~td||fƒ‚t|jƒ}t|jƒd}t|jƒd|?}t|||ƒD]}| ||f¡}|Vq´dS)aÓThe subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr)ú(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) rMr=rrrrOrHr¦r–r{) r\Úprefixlen_diffÚ new_prefixÚ new_prefixlenÚstartÚendÚstepZnew_addrZcurrentr r r rIps2     ÿÿ z_BaseNetwork.subnetscCsˆ|jdkr|S|dk rB||jkr(tdƒ‚|dkr8tdƒ‚|j|}|j|}|dkrftd|j|fƒ‚| t|jƒt|jƒ|>@|f¡S)aËThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr)r³z;current prefixlen is %d, cannot have a prefixlen_diff of %d)rMrrjr{rrrOr¢)r\r´rµr¶r r r rC¥s&    ÿÿþz_BaseNetwork.supernetcCs|jjo|jjS©z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rOÚ is_multicastrHr[r r r r»Îs ÿz_BaseNetwork.is_multicastcCshz:|j|jkr"t|›d|›d�ƒ‚|j|jko8|j|jkWStk rbtd|›d|›�ƒ‚YnXdS)Nz and z are not of the same versionz*Unable to test subnet containment between )rLr;rOrHrN)ÚaÚbr r r Ú _is_subnet_ofÚs   ÿz_BaseNetwork._is_subnet_ofcCs | ||¡S)z1Return True if this network is a subnet of other.©r¾r‚r r r r­æsz_BaseNetwork.subnet_ofcCs | ||¡S)z3Return True if this network is a supernet of other.r¿r‚r r r Ú supernet_ofêsz_BaseNetwork.supernet_ofcCs|jjo|jjS)úµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )rOÚ is_reservedrHr[r r r rÂîs ÿz_BaseNetwork.is_reservedcCs|jjo|jjS©z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rOÚ is_link_localrHr[r r r rÄúsÿz_BaseNetwork.is_link_localcCs|jjo|jjS)zÔTest if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )rOÚ is_privaterHr[r r r rÅs ÿz_BaseNetwork.is_privatecCs|j S)z×Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. ©rÅr[r r r Ú is_globals z_BaseNetwork.is_globalcCs|jjo|jjS)ú¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )rOÚis_unspecifiedrHr[r r r rÉs ÿz_BaseNetwork.is_unspecifiedcCs|jjo|jjS)ú±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )rOÚ is_loopbackrHr[r r r rË(s ÿz_BaseNetwork.is_loopback)r)N)r)N))rrrr rŒrŽrœržr¡r†r„r‘r¤r¥Ú functoolsÚcached_propertyrHr¦r~r§rªr«r¬r—rjr±r²rTrIrCr»Ú staticmethodr¾r­rÀrÂrÄrÅrÇrÉrËr r r r rSnsd            K0 5 )       rSc@s„eZdZdZdZdZdedZeZiZ dd„Z e dd „ƒZ e d d „ƒZ e d d „ƒZe dd„ƒZdd„Zedd„ƒZedd„ƒZdS)Ú_BaseV4zyBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. r rr#r)cCst|ƒSrzr^r[r r r rZHsz$_BaseV4._explode_shorthand_ip_stringcCs�||jkr†t|tƒr<|}d|kr.|jksjn| |¡n.z| |¡}Wntk rh| |¡}YnXt|  |¡ƒ}||f|j|<|j|S©aMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") r) Ú_netmask_cacher9rrr=rorsr rvr rk©riÚargrjr¢r r r Ú _make_netmaskKs   z_BaseV4._make_netmaskc Cs~|s tdƒ‚| d¡}t|ƒdkr.td|ƒ‚zt t|j|ƒd¡WStk rx}ztd||fƒd‚W5d}~XYnXdS)aTurn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. úAddress cannot be emptyÚ.rzExpected 4 octets in %rrú%s in %rN)rr%r&rrÚ from_bytesÚmapÚ _parse_octetr)riruZoctetsÚexcr r r rtes   z_BaseV4._ip_int_from_stringcCsŽ|s tdƒ‚| ¡r| ¡s,d}t||ƒ‚t|ƒdkrHd}t||ƒ‚|dkrl|ddkrld}t||ƒ‚t|dƒ}|d krŠtd |ƒ‚|S) a Convert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %réz$At most 3 characters permitted in %rÚ0rz%Leading zeros are not permitted in %ré éÿzOctet %d (> 255) not permitted)rrprqr&rr)riZ octet_strrfZ octet_intr r r rÚs      z_BaseV4._parse_octetcCsd tt| dd¡ƒ¡S)zÒTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. rÖrr)ÚjoinrÙr$r)rirmr r r r�£s z_BaseV4._string_from_ip_intcCs&t|ƒ d¡ddd…}d |¡dS)z�Return the reverse DNS pointer name for the IPv4 address. This implements the method described in RFC1035 3.5. rÖNrKz .in-addr.arpa)r$r%rà)r\Zreverse_octetsr r r r`°sz_BaseV4._reverse_pointercCs|jSrz©r=r[r r r Ú max_prefixlen¹sz_BaseV4.max_prefixlencCs|jSrzr’r[r r r r<½sz_BaseV4.versionN)rrrr r}rLÚ IPV4LENGTHr>r=rÑrZrrÔrtrÚr�r`r~râr<r r r r rÏ5s(    #   rÏc@sŒeZdZdZdZdd„Zedd„ƒZedd„ƒZee   ¡d d „ƒƒZ ee   ¡d d „ƒƒZ ed d„ƒZ edd„ƒZedd„ƒZedd„ƒZdS)r z/Represent and manipulate single IPv4 Addresses.©r,Ú __weakref__cCsrt|tƒr| |¡||_dSt|tƒrF| |d¡t |d¡|_dSt|ƒ}d|krbtd|ƒ‚|  |¡|_dS)a± Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv4Address('192.0.2.1') == IPv4Address(3221225985). or, more generally IPv4Address(int(IPv4Address('192.0.2.1'))) == IPv4Address('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. Nrrr"úUnexpected '/' in %r© r9rrrgr,rwrhrØr$rrt©r\rZaddr_strr r r Ú__init__Ès     zIPv4Address.__init__cCs t|jƒS©z*The binary representation of this address.)rr,r[r r r ÚpackedëszIPv4Address.packedcCs ||jjkS)z°Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within the reserved IPv4 Network range. )Ú _constantsÚ_reserved_networkr[r r r rÂðs zIPv4Address.is_reservedcs4t‡fdd„ˆjjDƒƒo2t‡fdd„ˆjjDƒƒS)áÃ``True`` if the address is defined as not globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exceptions: * ``is_private`` is ``False`` for ``100.64.0.0/10`` * For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_private == address.ipv4_mapped.is_private ``is_private`` has value opposite to :attr:`is_global`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. c3s|]}ˆ|kVqdSrzr ©Ú.0r?r[r r Ú sz)IPv4Address.is_private..c3s|]}ˆ|kVqdSrzr rïr[r r rñs)ÚanyrìÚ_private_networksÚallÚ_private_networks_exceptionsr[r r[r rÅûsþzIPv4Address.is_privatecCs||jjko|j S©ar``True`` if the address is defined as globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exception: For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_global == address.ipv4_mapped.is_global ``is_global`` has value opposite to :attr:`is_private`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. )rìÚ_public_networkrÅr[r r r rÇszIPv4Address.is_globalcCs ||jjkS)z­Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. ©rìÚ_multicast_networkr[r r r r»#s zIPv4Address.is_multicastcCs ||jjkS)z¤Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )rìÚ_unspecified_addressr[r r r rÉ.s zIPv4Address.is_unspecifiedcCs ||jjkS)z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )rìÚ_loopback_networkr[r r r rË9szIPv4Address.is_loopbackcCs ||jjkS)z’Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. ©rìÚ_linklocal_networkr[r r r rÄCszIPv4Address.is_link_localN)rrrr r}rér~rërÂrÌÚ lru_cacherÅrÇr»rÉrËrÄr r r r r Âs*#       r c@sxeZdZdd„Zejdd„ƒZdd„Zdd„Zd d „Z d d „Z e j Z e d d„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdS)rcCsD| |¡\}}t ||¡t||fdd�|_|jj|_|jj|_dS©NF)r)ryr rérr™r¢rM©r\rr'Úmaskr r r réPs   zIPv4Interface.__init__cCs|jjSrz©r™r¦r[r r r r¦XszIPv4Interface.hostmaskcCsd| |j¡|jfSr“©r�r,rMr[r r r rŽ\s ÿzIPv4Interface.__str__cCsFt ||¡}|r|tkr|Sz|j|jkWStk r@YdSXdSr£)r r„rVr™rN©r\rƒZ address_equalr r r r„`s  zIPv4Interface.__eq__cCsRt ||¡}|tkrtSz|j|jkp4|j|jko4|WStk rLYdSXdSr£)r r†rVr™rN©r\rƒZ address_lessr r r r†ls  ÿzIPv4Interface.__lt__cCst|j|jt|jjƒfƒSrz©r�r,rMrrr™rOr[r r r r‘xszIPv4Interface.__hash__cCs t|jƒSrz)r r,r[r r r r1}szIPv4Interface.ipcCsd| |j¡|jfSr¨rr[r r r r§�s ÿzIPv4Interface.with_prefixlencCsd| |j¡|jfSr¨©r�r,r¢r[r r r rª†s ÿzIPv4Interface.with_netmaskcCsd| |j¡|jfSr¨©r�r,r¦r[r r r r«‹s ÿzIPv4Interface.with_hostmaskN)rrrrérÌrÍr¦rŽr„r†r‘rYr|r~r1r§rªr«r r r r rNs       rc@s2eZdZdZeZddd„Zee  ¡dd„ƒƒZ dS) raeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 Tcs¤| |¡\‰}tˆƒ|_| |¡\|_|_t|jƒ}|t|jƒ@|krl|rXtd|ƒ‚nt|t|jƒ@ƒ|_|j|jdkr†|j |_ n|j|jkr ‡fdd„|_ dS)aInstantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.2.0/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. ú%s has host bits setr)cs tˆƒgSrz)r r ©r'r r ÚÒóz&IPv4Network.__init__..N) ryr rOrÔr¢rMrrrr=ržrœ©r\rrrrër r r ré s#  ÿ  zIPv4Network.__init__cCs&|jtdƒko|jtdƒk o$|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. ú 100.64.0.0/10)rOrrHrÅr[r r r rÇÔs  ÿþzIPv4Network.is_globalN)T) rrrr r r—rér~rÌrþrÇr r r r r‘s   4rc@s¤eZdZedƒZedƒZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒed ƒed ƒedƒedƒedƒgZedƒedƒgZ edƒZ e dƒZ dS)Ú_IPv4Constantsz169.254.0.0/16z 127.0.0.0/8z 224.0.0.0/4rz 0.0.0.0/8z 10.0.0.0/8z 172.16.0.0/12z 192.0.0.0/24z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32z 192.0.0.9/32z 192.0.0.10/32z0.0.0.0N) rrrrrýrûrùr÷rórõrír rúr r r r rãs0òþrc@sžeZdZdZdZdZdedZdZe dƒZ eZ iZ e dd „ƒZe d d „ƒZe d d „ƒZe dd„ƒZe ddd„ƒZdd„Zdd„Zedd„ƒZedd„ƒZdS)Ú_BaseV6zyBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. r r8r#r)rlZ0123456789ABCDEFabcdefcCsl||jkrbt|tƒr<|}d|kr.|jksFn| |¡n | |¡}t| |¡ƒ}||f|j|<|j|SrÐ)rÑr9rrr=rorsrrkrÒr r r rÔ s    z_BaseV6._make_netmaskc CsÜ|s tdƒ‚| d¡}d}t|ƒ|kr:d||f}t|ƒ‚d|dkr¶zt| ¡ƒj}Wn4tk rŒ}ztd||fƒd‚W5d}~XYnX| d |d ?d @¡| d |d @¡|jd }t|ƒ|kräd |d |f}t|ƒ‚d}td t|ƒd ƒD]*} || sú|dk �r d|}t|ƒ‚| }qú|dk �rÈ|} t|ƒ|d } |d�sl| d 8} | �rld}t||ƒ‚|d�s”| d 8} | �r”d}t||ƒ‚|j| | } | d k�r2d}t||jd |fƒ‚njt|ƒ|jk�rîd}t||j|fƒ‚|d�sd}t||ƒ‚|d�s"d}t||ƒ‚t|ƒ} d} d} znd} t| ƒD] } | d K} | |  || ¡O} �q@| d | K} t| dƒD] } | d K} | |  || ¡O} �qz| WSt k �rÖ}ztd||fƒd‚W5d}~XYnXdS)zùTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. rÕú:rÜz At least %d parts expected in %rrÖrKr×Nú%xr éÿÿr)z!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %r) rr%r&r rBr,rEÚ _HEXTET_COUNTr–Ú _parse_hextetr)riruÚpartsZ _min_partsrfZipv4_intrÛZ _max_partsZ skip_indexÚiZparts_hiZparts_loZ parts_skippedrmr r r rt4s„    $               z_BaseV6._ip_int_from_stringcCs>|j |¡std|ƒ‚t|ƒdkr4d}t||ƒ‚t|dƒS)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rrz$At most 4 characters permitted in %rr )Ú _HEX_DIGITSÚ issupersetrr&rr)riZ hextet_strrfr r r rœs     z_BaseV6._parse_hextetc Cs¢d}d}d}d}t|ƒD]>\}}|dkrN|d7}|dkr<|}||krV|}|}qd}d}q|dkrž||}|t|ƒkr~|dg7}dg|||…<|dkrždg|}|S)aäCompresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. rKrrÝr)Ú)Ú enumerater&) riÚhextetsZbest_doublecolon_startZbest_doublecolon_lenZdoublecolon_startZdoublecolon_lenÚindexZhextetZbest_doublecolon_endr r r Ú_compress_hextets¶s0ÿ   z_BaseV6._compress_hextetsNcsZ|dkrt|jƒ}||jkr$tdƒ‚d|‰‡fdd„tdddƒDƒ}| |¡}d  |¡S) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too largeú%032xcs&g|]}dtˆ||d…dƒ‘qS)rrr )rr©rðr›©Zhex_strr r Ú ûsz/_BaseV6._string_from_ip_int..rrrr)rrr,r>rr–rrà)rirmrr r!r r�æs   z_BaseV6._string_from_ip_intcsŒt|tƒrt|jƒ}nt|tƒr,t|jƒ}nt|ƒ}| |¡}d|‰‡fdd„tdddƒDƒ}t|ttfƒr‚dd  |¡|j fSd  |¡S) z¬Expand a shortened IPv6 address. Args: ip_str: A string, the IPv6 address. Returns: A string, the expanded IPv6 address. rcsg|]}ˆ||d…‘qS)rr r r!r r r"sz8_BaseV6._explode_shorthand_ip_string..rrrr”r) r9rr$rOrr1rtr–rSràrM)r\rurmrr r!r rZs     z$_BaseV6._explode_shorthand_ip_stringcCs&|jddd… dd¡}d |¡dS)z�Return the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. NrKrrrÖz .ip6.arpa)r]Úreplacerà)r\Z reverse_charsr r r r`sz_BaseV6._reverse_pointercCs|jSrzrár[r r r râ!sz_BaseV6.max_prefixlencCs|jSrzr’r[r r r r<%sz_BaseV6.version)N)rrrr r}rLÚ IPV6LENGTHr>rÚ frozensetrr=rÑrrÔrtrrr�rZr`r~râr<r r r r r s0   g  /   rc@s´eZdZdZdZdd„Zedd„ƒZedd„ƒZed d „ƒZ ed d „ƒZ ed d„ƒZ ee   ¡dd„ƒƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZdS)rz/Represent and manipulate single IPv6 Addresses.räcCsrt|tƒr| |¡||_dSt|tƒrF| |d¡t |d¡|_dSt|ƒ}d|krbtd|ƒ‚|  |¡|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nr rr"rærçrèr r r ré0s     zIPv6Address.__init__cCs t|jƒSrê)r!r,r[r r r rëTszIPv6Address.packedcCs ||jjkSrºrør[r r r r»Ys zIPv6Address.is_multicastcst‡fdd„ˆjjDƒƒS)rÁc3s|]}ˆ|kVqdSrzr r r[r r rñmsz*IPv6Address.is_reserved..)ròrìÚ_reserved_networksr[r r[r rÂds zIPv6Address.is_reservedcCs ||jjkSrÃrür[r r r rÄoszIPv6Address.is_link_localcCs ||jjkS©a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )rìÚ_sitelocal_networkr[r r r Ú is_site_localys zIPv6Address.is_site_localcsHˆj}|dk r|jSt‡fdd„ˆjjDƒƒoFt‡fdd„ˆjjDƒƒS)rîNc3s|]}ˆ|kVqdSrzr rïr[r r rñœsz)IPv6Address.is_private..c3s|]}ˆ|kVqdSrzr rïr[r r rñ�s)Ú ipv4_mappedrÅròrìrórôrõ)r\r*r r[r rŇs þzIPv6Address.is_privatecCs|j SrörÆr[r r r rÇ szIPv6Address.is_globalcCs |jdkS)rÈrr€r[r r r rɱs zIPv6Address.is_unspecifiedcCs |jdkS)rÊr)r€r[r r r r˼s zIPv6Address.is_loopbackcCs |jd?dkrdSt|jd@ƒS)z¶Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. rrNìÿÿ©r,r r[r r r r*Çs zIPv6Address.ipv4_mappedcCs4|jd?dkrdSt|jd?d@ƒt|jd@ƒfS)zÛTuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Né@r+r,r[r r r ÚteredoÔs ÿzIPv6Address.teredocCs$|jd?dkrdSt|jd?d@ƒS)zÎReturn the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPr+r,r[r r r Ú sixtofourãs zIPv6Address.sixtofourN)rrrr r}rér~rër»rÂrÄr)rÌrþrÅrÇrÉrËr*r/r2r r r r r*s8$           rc@s�eZdZdd„Zejdd„ƒZdd„Zdd„Zd d „Z d d „Z e j Z e d d„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdS)rcCsD| |¡\}}t ||¡t||fdd�|_|jj|_|jj|_dSrÿ)ryrrérr™r¢rMrr r r réós   zIPv6Interface.__init__cCs|jjSrzrr[r r r r¦ûszIPv6Interface.hostmaskcCsd| |j¡|jfSr“rr[r r r rŽÿs ÿzIPv6Interface.__str__cCsFt ||¡}|r|tkr|Sz|j|jkWStk r@YdSXdSr£)rr„rVr™rNrr r r r„s  zIPv6Interface.__eq__cCsRt ||¡}|tkrtSz|j|jkp4|j|jko4|WStk rLYdSXdSr£)rr†rVr™rNrr r r r†s  ÿzIPv6Interface.__lt__cCst|j|jt|jjƒfƒSrzrr[r r r r‘szIPv6Interface.__hash__cCs t|jƒSrz)rr,r[r r r r1 szIPv6Interface.ipcCsd| |j¡|jfSr¨rr[r r r r§$s ÿzIPv6Interface.with_prefixlencCsd| |j¡|jfSr¨rr[r r r rª)s ÿzIPv6Interface.with_netmaskcCsd| |j¡|jfSr¨rr[r r r r«.s ÿzIPv6Interface.with_hostmaskcCs|jdko|jjS)Nr)r,r™rÉr[r r r rÉ3szIPv6Interface.is_unspecifiedcCs|jdko|jjSr�)r,r™rËr[r r r rË7szIPv6Interface.is_loopbackN)rrrrérÌrÍr¦rŽr„r†r‘rYr|r~r1r§rªr«rÉrËr r r r rñs(        rc@s2eZdZdZeZd dd„Zdd„Zedd„ƒZ d S) ravThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 Tcs¤| |¡\‰}tˆƒ|_| |¡\|_|_t|jƒ}|t|jƒ@|krl|rXtd|ƒ‚nt|t|jƒ@ƒ|_|j|jdkr†|j |_ n|j|jkr ‡fdd„|_ dS)aæInstantiate a new IPv6 Network object. Args: address: A string or integer representing the IPv6 network or the IP and prefix/netmask. '2001:db8::/128' '2001:db8:0000:0000:0000:0000:0000:0000/128' '2001:db8::' are all functionally the same in IPv6. That is to say, failing to provide a subnetmask will create an object with a mask of /128. Additionally, an integer can be passed, so IPv6Network('2001:db8::') == IPv6Network(42540766411282592856903984951653826560) or, more generally IPv6Network(int(IPv6Network('2001:db8::'))) == IPv6Network('2001:db8::') strict: A boolean. If true, ensure that we have been passed A true network address, eg, 2001:db8::1000/124 and not an IP address on a network, eg, 2001:db8::1/124. Raises: AddressValueError: If address isn't a valid IPv6 address. NetmaskValueError: If the netmask isn't valid for an IPv6 address. ValueError: If strict was True and a network address was not supplied. r r)cs tˆƒgSrz)rr r r r r zr z&IPv6Network.__init__..N) ryrrOrÔr¢rMrrrr=ržrœr r r r réLs  ÿ  zIPv6Network.__init__ccs<t|jƒ}t|jƒ}t|d|dƒD]}| |¡Vq&dS)z¢Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r)Nr•r˜r r r rœ|s  zIPv6Network.hostscCs|jjo|jjSr')rOr)rHr[r r r r)ˆs ÿzIPv6Network.is_site_localN)T) rrrr rr—rérœr~r)r r r r r<s   0 rc@sêeZdZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒedƒg Zed ƒed ƒedƒedƒedƒedƒgZedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒed ƒgZed!ƒZ d"S)#Ú_IPv6Constantsz fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z64:ff9b:1::/48z100::/64z 2001::/23z 2001:db8::/32z 2002::/16zfc00::/7z 2001:1::1/128z 2001:1::2/128z 2001:3::/32z2001:4:112::/48z 2001:20::/28z 2001:30::/28z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10N) rrrrrýrùrórõr&r(r r r r r3˜sJõú ø r3)T)#r Ú __version__rÌrãr$rrr rrrrr!r(r2r6r@rJrRrXrYÚtotal_orderingr:rSrÏr rrrrìrrrrr3r r r r ÚsX #7163:I CR& HK\-